Back to overview
Degraded
External telephony provider disruption
Oct 20 at 10:00am CEST
Affected services
Flows
Resolved
Oct 20 at 07:04pm CEST
All issues resolved
Affected services
Created
Oct 20 at 10:00am CEST
We are currently experiencing intermittent issues with our external telephony provider affecting inbound and outbound calls. The issue has been identified, and we are monitoring the provider’s recovery efforts.
Affected services